Jump to content

mold or fungus or velvet etc


coco

Recommended Posts

  • Regular Member

The new plants, less the pothos and more the unnamed plant (from the LFS) had grown these small white balls of what I imagine was a form of mold...?

I learned after the fact that when adding new plants, they should've be treated with bleach. D'oh!

If you were to start over knowing what you do now, in my situation, and no other obvious problem, what would ya'll suggest? Mind you, the strange white mold looking stuff was scraped and currently the last is being filtered away. Another water change tomorrow will follow.

Sorry for the delay replying, being away and lost site access when we got back.

He didn't make it. We remember those small white balls, OH was so curious about them he squeezed one of them, out of the tank, and it bursted everywhere -white milky fluid, like pus in a zit.

Since i don't actually ever found out what that white crappy slimey stuff was, i don't know what to undo, if i could have it all back again. Probably not add the plants??!!! don't know. Good luck in your fight!

Link to comment
Share on other sites

  • Replies 103
  • Created
  • Last Reply

Top Posters In This Topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...