Jump to content

Fungus In New Nursery Tank...


Recommended Posts

  • Regular Member

Well Just a few days after I set up at 5 gal and I already have white stringy looking things floating around (In my filter and on my banana plant.) I didnt know what to do so I figured I'd put some fungus guard in there.?. Good or bad? I think the brand was jungle. I also have some aponogeton bulbs that I just put in tonight I don't want my plants to die. What do I do?

Link to comment
Share on other sites

  • Regular Member

It sounds like staghorn algae. Does it look like this, this, or this(when out of water)? I'm currently dealing with it in my tank after some live plants brought it in. Blackouts don't seem to faze it. It seems the best thing to do with staghorn algae is to manually remove as much as possible, but ripping/scraping it off of tank equipment and trimming of infested leaves of live plants. If you are able to remove all of the existing algae mass, it doesn't seem to be able to reappear again through spores.

Another picture: sometimes it puts out spore pockets (I think) or just collects debris, so it looks like an old cobweb like this

Edited by Calluna
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...