Jump to content

Noisy Aquaclear 110


Recommended Posts

  • Regular Member

I have a 110gal tank with 6 goldies in it. It has 2 aquaclear 110's on it. I clean it out weekly. About three weeks ago i was cleaning it out and removed all the media so i could get down to clean the impellers. I then put it all back together and started it up when the tank was finished filling. When it started up it was making a quiet grumbling sound but it wasn't really all that noticeable. I just finished cleaning it out today and when I put it all back together and started it up again it's pretty loud this time. It doesn't sound like it's rattling apart or anything but it doesn't really sound normal. Has anybody had a problem before with noisy 110's?

Link to comment
Share on other sites

  • Regular Member

I have never had the problem with my 110 but have a couple of ideas. Perhaps one of the impeller blades were bent when it was being cleaned? Or maybe a small piece of hard debris in the impeller cavity?

Link to comment
Share on other sites

  • Regular Member

I had that happen, well, at least something that sounds like it. What it was for me, was that the impeller wasn't properly seated. It took two tries to get it back in right, but once I did, it was quiet as can be. Just a thought....

Link to comment
Share on other sites

  • Regular Member
I had that happen, well, at least something that sounds like it. What it was for me, was that the impeller wasn't properly seated. It took two tries to get it back in right, but once I did, it was quiet as can be. Just a thought....

Of course, I dont know why I didn't think of that too. That has been an issue before on my marineland filters.

Link to comment
Share on other sites

  • Regular Member

I would definitely look to a mechanical issue, since you said that the noise had not started until AFTER you cleaned the impellers. I would triple-check to make sure that, like Lynda said, the impellers are properly seated and, like br553 suggested, there is not anything that inadvertently fell in.

ACs in my experience are quiet, reliable filters.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...