Jump to content

Anybody Not Sure If They Feel Well


nick11380

Recommended Posts

  • Regular Member

A few days ago I bought an API master test kit and was doing a lot of testing. The first day I tested 8 aquariums for Ammonia, Nitrite and Nitrate. Afterwards it seemed like my breathing was slightly irritated but I wasn't sure and the next morning it passed so I didn't think much about it.

Last night I did a bunch more testing. (7) Ammonia tests, (2) KH, (1) Copper, (2) Nitrite (2) Nitrate. Again my breathing felt slightly irritated and this morning I'm feeling slightly sicky and eating my breakfast I'm not really hungry.

I did the tests at full arms length and didn't have any accidents. I may have gotten a little bit on my hands rinsing out the test tubes and if some of the solution dripped down the outside of the test tube when the cover needed to be removed to add more testing drops.

There is a caution label on some of the tests. So there are some dangers. So I'm wondering if anybody else has felt slightly not well after testing there water?

Link to comment
Share on other sites

  • Regular Member

You have tested quite a few tanks, and I only have 2, so I can't really relate. Also, I'm a clean hand freak (well - almost a freak) and I wear plastic gloves when I test, and I also put a paper napkin around the tube when I shake it. When I put the drops in, I hold my breath so I don't inhale any vapors or what have you. :idont

I hope you feel better soon! :exactly

Debbie

Link to comment
Share on other sites

  • Regular Member

I've always used API test kits. I've gotten it on my hands and never really paid much attention to being "ultra" careful with any of the chemicals. They are labeled as irritants but I think that means under prolonged exposure. I've never had any problems testing my water.

I was an OSHA nightmare at the print shop I worked in, I've been exposed to numerous chemicals and dyes and have not felt any effects from exposure to chems. Maybe I've got Neoprene skin? :yikes

Link to comment
Share on other sites

  • Regular Member

When I use my API kit everything is fine, but the red sea kit I have has A LOT of fumes. I always get a little light headed when I use that kit; I would never test more than one tank at a time with it.

Link to comment
Share on other sites

  • Regular Member

wow! i never took notice to how i feel after i test. maybe i should pay more attention and be sure not to get any one me.

Link to comment
Share on other sites

  • Regular Member

im never careful with the tests, once the cap came off and it kinda went everywhere lol and i always get it on my hands lol....and occasionally my mother's precious carpet :whatjust: . I've never felt sick or nothing though although the stuff can kinda sting if u dont wash it off right away lol. But then again i dont test often, only when the fish r sick and dont get better after a big waterchange or when I have nothing better to do lol

Edited by Shamu23
Link to comment
Share on other sites

  • Regular Member

WoW :unsure: I never heard if those problems!!! I have used them for years, and have never really been especially careful. I have spilled some occasionally & wiped it up with a paper towel....no problems!!

Do you think it is an allergy-like problem?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...