Jump to content

Worlds Loudest Filter....


Recommended Posts

  • Regular Member

Ugh. I just got my new filter set up in my new tank. The guy at the fish store said it was absolutely SILENT. He guaranteed me that it would be so much quiter than my aquaclear filter. So i set it up and its making this awful *GRRRRRRRRRAAAAWWWWWWWWWWWWWWWWHHHHHHHHHIIIIIIIIII

RRRRRRRRRRRR* noise... I have to be able to sleep with the filter running cuz the tank is in my room....... ugh. And my store doesnt have any of the aquaclear filters right now so i cant go and buy a stronger aquaclear. So yeah..... if youre looking for a quiet fiter.... dont go with the Marineland Emporer 280. its awful.

Link to comment
Share on other sites

  • Regular Member

does the noise it makes sounds like a grinding noise?

i used to have a whisper filter that make a lot noise, it was because of the propeller, we fixed it and now it's silent lol :D humm, that's weird, a lot of members here have Emperor filters, and they really like it :unsure:

Link to comment
Share on other sites

  • Regular Member

it does a little bit but i've already fiddled around with the thing and its not the prop. good thinkin' though ;)

i took out the impeller and checked to make sure everything was secure. i read all the instructions... everything is working just fine.

i cant WAIT until i find the aquaclear that i need. then i will be able to sleep!

Link to comment
Share on other sites

  • Regular Member

...O__o

I have an emperor 280 for my 40 gallon and am getting an emperor 400(on Friday, whoot!) as an addition to the 40 gallons filtration. It is almost completely silent for me! The only "problem" would be the splash as it hits the water, though I am so used to the sound of splashing in the tanks that I probably would be unable to sleep without it.

I'm sorry it did not work out for you, perhaps you could trade it in for another to try, and if that does not work ask for a refund?

Link to comment
Share on other sites

  • Regular Member

I had one "bad" Emperor 400.....it literally would not run - could not get primed. I fiddled and fiddled and could not see ANY reason that this would be so. I finally simply took it back to the store and got it replaced with another. The second was GREAT.

I love my Emperors. They are my favorite filters. Other than the lemon I spoke of above, I have never had one fail or be noisy or bad.

Do you by any chance have any air bubbles from a bubble bar or wand or something that are being sucked up into the intake? These will make tons of noise.

Is the intake tube - the bendy one that goes over the top into the filter - seated really deeply and firmly in place? I had one other filter that had a bit of mold-flashing that was keeping the tube from seating properly - resulting in noise. It should all sit firmly and tightly in place.

If you cannot get it to go properly - take it back and get a replacement. I have. Emperors are GOOD filters - and yours should not be giving you these problems.

Link to comment
Share on other sites

  • Regular Member

hmmm well i do have a bubble wall near the filter, but i turn it off at night because the pump is a little noisy. Turning it off didnt change anything regarding the filter though. I thought i would try to sleep with the filter going last night..... i saw every hour of the night until i finally gave up at 5am and had to unplug it (i plugged it right back in as soon as i woke up a couple hours later). worst sleep EVER.

i guess i will take it back and exchange it for another. if i have the same problem, im going back to my aquaclear!!!

Link to comment
Share on other sites

  • Regular Member

Its an awful loud noise....... i have no idea what is causing it, but it sounds exactly like my old aquaclear did right before it completely broke. I've taken the whole thing apart a bunch of times; made sure everything was secure and in place. No matter what i do, its just making noise. i cant even explain what the noise is. its not a grinding noise..... its nothing about the impeller..... its kind of just..... a really loud, uneven whirring noise.... with the occasional scratchy noise once in a while.... i dont know how to explain it!! :krazy:

Link to comment
Share on other sites

  • Regular Member
can you maybe take a video of the filter when its making the noise, then, we'll be able to hear the noise :unsure::)

good idea! but ugh i just went to go do that and now my camera is broken.......... so no video........

Link to comment
Share on other sites

  • Regular Member
Its an awful loud noise....... i have no idea what is causing it, but it sounds exactly like my old aquaclear did right before it completely broke. I've taken the whole thing apart a bunch of times; made sure everything was secure and in place. No matter what i do, its just making noise. i cant even explain what the noise is. its not a grinding noise..... its nothing about the impeller..... its kind of just..... a really loud, uneven whirring noise.... with the occasional scratchy noise once in a while.... i dont know how to explain it!! :krazy:

The emperors work best when the water level is high, due to suction needs. If your tank is filled to the brim and you're still experiencing the noise when you know that you've primed well, than you probably have a malfunctioning unit (that sounds so funny!) and need to replace it.

Really, the emperors are wonderful!

Link to comment
Share on other sites

  • Regular Member

Hmmm i went to another pet store to see if they have any of the emporers so i could exchange mine but they didnt have any. They had my aquaclear though ^_^ so i bought one of those. its sooooooooooo quiet :D i think i will be able to sleep tonight hahaha

Link to comment
Share on other sites

  • 3 weeks later...
  • Regular Member
does the noise it makes sounds like a grinding noise?

i used to have a whisper filter that make a lot noise, it was because of the propeller, we fixed it and now it's silent lol :D humm, that's weird, a lot of members here have Emperor filters, and they really like it :unsure:

Just out of curiosity, how did you fix it? My Whisper isn't loud, but it has a slight hum. I am not too worried about it because it doesn't bother me, but I would like to try what you did to see if I can get it SILENT!! It is in my bedroom afterall.

Daniel

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...