Jump to content
Sign in to follow this  
Guest kscoleman

Aquaclear 110's

Recommended Posts

Guest kscoleman

I have read a lot of great reviews for the Aquaclear filters and I do love mine too for the quietness and because it is not costly to maintain since you can just rinse the sponges etc. but am I the only one that can't keep the tray that holds the sponge in on the one side? Mine always floats up and I have to rig something to sit on top of the sponge to hold it down. On one I have a glass plate that sits in the filter and projects out over the waterfall area. That is a pain. There is such a tiny lip on the one side, it doesn't hold it down for me. What am I doing wrong? Be careful with your answers, I am blond and sensitive!!!

Share this post


Link to post
Share on other sites

I have had this problem occasionaly with one of my aquaclear filters. Usually when the one side foats up I need to take apart the filter and clean it, and put the filter media back in with the motor off and the water drained out of the filter box. That usually fixes it for a few weeks.

Share this post


Link to post
Share on other sites

Hmmm,I have never had that problem.Do you just have sponge in it?I have 2 sponge and ceramic rings for the top layer in all three of my AC's,maybe they hold it down......

Share this post


Link to post
Share on other sites

How often by chance do you rinse the filter sponge out in tank water? I own quite a few of them,and the only time that they'll do that is when the sponge needs a good rinsing.I have to do that even more often in my Trop tanks,as they all are planted and the sponges gets gunky quicker. :rolleyes:

Share this post


Link to post
Share on other sites
:) I would guess this could be avoided by cleaning out your filter a little more often. I do not mean scrub it and kill all the good bacteria, but just rinsing out your sponge in some tank water during water changes should prevent this from happening.

Share this post


Link to post
Share on other sites
Guest kscoleman

It is not the sponge so much because the ceramic rings help with that to a degree. It is the plastic u like basket piece the sponge sits it. On the side next to the intake tube there is a slit on the "basket' that a little ledge on the side of the chamber holding the intake tube fits over. The other side of the filter has a tiny little lip which doesn't extend into the slot enough to hold it in place. So.........that side always floats up, even with the rings. I have had all 3 of mine for maybe 3 years. Maybe it is an old style. I will have to look at the LFS next time. Can you run the filters without the basket?

Share this post


Link to post
Share on other sites

I have this happen sometimes too. I take it as a sign I need to clean my foam pieces. I clean them then it quits. :hmm

Share this post


Link to post
Share on other sites
Guest kscoleman

I will have to play around with one I am not using right now and see if it stays in place. I never would have guessed that was the problem. I do have less trouble with my tropical tank (all my plants are fake) than my goldfish tank. My goldfish filter always requires more maintenance. Thanks for everyone's help.

Share this post


Link to post
Share on other sites

I have this problem too. even after i clean the sponge and stuff. i just put a long thin rock over the rings and it stays down

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...