Jump to content

What Is Wrong With My Betta?


Ash

Recommended Posts

  • Regular Member

Ok, about a week ago I notice a tiny white thread like thing hanging from the chin of me betta. I looked at pictures of anchor worms and thought that is what is must be...even though I had no idea how he could have gotten it as nothing new has be introduced in monthes. I treated for parasites twice now and in the last two days has gotten such huge lumps and more white stringy things on his face. After the first round of meds, it seemed to be clearing up. Then he got one on his tail. It was a white string that went through and through so it hung out both sides. I pulled that of with a tweezers, but it didn't come of easily.

What is wrong with him? Is it bacterial? What should I use and should I treat the whole tank? It is a six gallon eclipse with the bio wheel filter. There is him, two African Dwarf Frogs, a snail and my last two remaing white cloud minnows.

Ammoinia is 0

Nitrite 0

Nirtate about 10

and ph 7

He's a nnnnnn fish that I've had for almost a year now. I can tell though that he's a pretty old guy. He was old when I got him...I think that maybe he was a breeder and just sold when he ran out of juice.

1074199-M.jpg

More photos

betta photos

Link to comment
Share on other sites

  • Regular Member

Are the "strings" somewhat solid or are they more tufty?

What med did you use to treat?

From the pics, it looks more like fungus or bacteria than parasitic. Esp. if you haven't had any new additions (and don't share equipment with tanks that have had new additions) I'd be inclined to assume that's what it is. Are any of his tankmates unwell?

Link to comment
Share on other sites

  • Regular Member

No, the strings are definatly more on the solid side. When I pulled the ones off his tail they really clung on which made me think that it was an anchor worm. I didn't do anything with the ones on this face. They kind of remind you of a bad pimple. When the white oozes out it is solid for awhile, then when I check back it is gone...kind of like it fell off or dissolved. Everyone in with him is doing fine. The first I noticed the tiny little string when it started was the day after I cleaned the tank and stirred up the goo from the gravel. Maybe he had some scrapes there and the dirt caused it to get infected...is that possible? Every once and a while he get scrapes on his head from rooting around the rocks and driftwood.

I treated him with Jungle Parasite Clear (I think that is what it is called without looking at the box...it's those fizz tablets and was the only thing I could get local). I just checked on him now and it seems to be better. It is really weird...it seems to get better, then fill up, then drain and look better again. So I guess it is some kind of an infection. I have Maracyn one and two on hand, but I am going to a large pet store on Saturday so I could something else there. Oh, and should I treat the whole tank, since he's been oozing for a day or two now or just him? I don't know how meds are on frogs and snails.

Thanks

Link to comment
Share on other sites

  • Regular Member

Your frogs and snails would probably not do well with antibiotics so you would probably want to move those guys before treating. Do you have another tank you could put them in while you treat? Ive seen similar things to that before and my best guess too would be bacterial. BTW hes a really beautiful betta! I hope you get things cleared up soon.

Link to comment
Share on other sites

  • Regular Member

Thanks...he is a really great looking guy. I'll have to post a picture of him looking a little better then he is right now...I just can't find what disc they are on. I have a little 3 gallon that should hold the frogs over until I get done medicating him.

Do you think that I should treat with the Maracyn 1 or 2 or just get something different. I don't have a clue about this.

Link to comment
Share on other sites

  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...