Jump to content
Sign in to follow this  
katalisp

Q about ich treatment

Recommended Posts

Hi All,

 

I lost Celestine today. She got icy three days ago. I searched the site and found info. Removed both her and Prospero to the quarantine tank. Increased the salt to 3% over three days and the heat to 75-78 over two days. She looked like she was doing well then went down today. I'm treating the tank with higher temps and bought a UV sterilizer. Emptied the tank almost all the way and did a intensive substrate vacuum.  Propsero looks good. He never had any signs of ich but I knew I couldn't treat the tank with salt because of the plants. The tank parameters were fine. Everythging was at 0% and PH remained at 7.8. The fish did come from Petco so I'm not super surprised. I just want to make sure I'm taking care of Prospero correctly. Should I lower to salt back down to 1% since he never showed any signs  of ich? I won't put  him back in the big tank until 12 weeks is up because I want to make sure no ich remains in the big tank. Oh and I also do a 50% water change daily, matching the temp as close as possible. 

 

 

Share this post


Link to post
Share on other sites

Gotta love spell check - that would be ich not icy - gallows humor

Share this post


Link to post
Share on other sites

And I'm clearly having trouble editing my own posts. That would be 2 weeks not 12 weeks. 

Share this post


Link to post
Share on other sites

I recently had a ich problem. I had my tank at .03% salt and 79 heat for several weeks until it went away. Salt and heat did the trick. Some of my fish reactions differed from others. I would definitely keep up with WC's and adding the proper salt % back into the tank.

What watt is the UV? A 9 watt won't cut it.

Also I am very sorry to hear about the loss of your fish :(

Edited by Cdionne77

Share this post


Link to post
Share on other sites

I also kept heat and salt up even after the ich was gone, I believe for a week after, just to be safe it was completely gone. I'm pretty sure it was a week after, I don't have my log book on me.

Share this post


Link to post
Share on other sites

I am sorry I thought you had another fish that also had ich. I had to go back and read your post again ..The one you said that shows no signs of ich, is he a new fish? I would be weary about dropping the salt anyway if it's a brand new fish.

Share this post


Link to post
Share on other sites

I'd continue treating all the fish that were in the tank even if they hadn't shown any dots yet. When I treated for ich I kept the tank at 0.3% Salt (3 grams per litre) and 82f for 2 weeks after the last dot had disappeared. Also increased aeration since the tank was so much warmer than usual

Edited by FishyMandy

Share this post


Link to post
Share on other sites

I'd continue treating all the fish that were in the tank even if they hadn't shown any dots yet. When I treated for ich I kept the tank at 0.3% Salt (3 grams per litre) and 82f for 2 weeks after the last dot had disappeared. Also increased aeration since the tank was so much warmer than usual

:bingo:

Share this post


Link to post
Share on other sites

Thanks everyone. At least I know i'm doing the right thing. Forgot to say I have an air stone going on high in the tank. This forum is fantastic for all the info and looking through past posts to find similar situations. 

Share this post


Link to post
Share on other sites

Thank you. I was a bit bummed Celestine was so friendly and always curious. I feel sorry for Prospero. He doesn't see well and he bonded with Celestine. He followed her everywhere :-(  I wish I had caught the ich sooner. I just seemed to pop up one AM and it was all over her. Once we get through this, I'll be looking at a better source for fish. After killing off my expensive plants I was wary of spending a lot on the fish since I'm a newbie. Now I get that it would have been better to find a better fish store. I've researched a couple in Seattle that have a good rep. I'll also get a GH KH test kit, just in case that was a factor. The Hamburg Matten Filter and the plants really keep the parameters down. They've always been 0 across the board since the tank cycled. I still change the water because it needs a good vacuum every week.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
  • Create New...