Jump to content

Loud canister filter


Recommended Posts

  • Regular Member

I just bought an APS 2000ef for my 45g tank and set it up but it's really noisy. It's like a constant vibration sound coming from the filter head. I've tried taking the impeller out then putting it back in and priming the filter again but it just stays loud. Any idea how to fix this?

Link to comment
Share on other sites

  • Regular Member

I just bought an APS 2000ef for my 45g tank and set it up but it's really noisy. It's like a constant vibration sound coming from the filter head. I've tried taking the impeller out then putting it back in and priming the filter again but it just stays loud. Any idea how to fix this?

Is the impeller rattling?  If so, it may just need a few weeks to break in and get slimed up :idont

Link to comment
Share on other sites

  • Helper

You may also try tipping your anister forward and backward, then side to side. Mine was running really load and it turned out it was trapped air bubbles interfering with proper pumping and pressure. It went back to almost silent after that. And yes, do fill the media trays sufficiently!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...