Jump to content

"Quiet" canister filter driving me insane!


Recommended Posts

  • Regular Member

:hi

I ordered a canister filter not long ago that I received yesterday and set up straight away. First attempt the intake hose burst off and wrecked my wall paper, my light controller and some electronics nearby. Yay! My father fixed the tubes on for me afterwards and there's no way they're coming off now. Ha. Take that intake hose.

And now, it's been set up for over 24 hours, both my father and I tried our absolute best to get the air out of the system, made sure it was completely primed, the impeller was clear and nothing could rattle and it still makes a horrendous noise! This is an All Pond Solutions EF1000. I've seen reviews of people saying the filter only makes a humming noise for them but apparently this one doesn't like me.

My tanks were moved to my bedroom not long ago so please play nicely, filter. I've been sentenced to earplugs.

 

Any suggestions?  :scared

 

Thanks!

Link to comment
Share on other sites

  • Regular Member

Try tilting the filter until the outflow is the highest point, then jiggle it rapidly back and forth to release any air that might be trapped. This is what I have to do with mine, anyway. (It's a SunSun though.)

What kind of noise is it making?

Link to comment
Share on other sites

  • Regular Member

Try tilting the filter until the outflow is the highest point, then jiggle it rapidly back and forth to release any air that might be trapped. This is what I have to do with mine, anyway. (It's a SunSun though.)

What kind of noise is it making?

^^ this

 

I also press the primer button while it's filtering. That seems to get the most air out.

Link to comment
Share on other sites

  • Regular Member

I have the EF2000 and it's really quiet, mine's in my bedroom as well. A friend has the EF1000 too and it's also really quiet. Maybe yours is faulty? It may be worthwhile speaking with AllPonds customer service department and see if you can get a replacement. Also, as others have suggested, I sometimes find that after I do a canister clean and start it up again I need to tilt it from side to side to get trapped air out even after I've primed it.

Edited by Ruby
Link to comment
Share on other sites

  • Regular Member

Have you checked the impeller shaft? My Sunsun was very noisy when I received it. It turned out the impeller shaft had broken during shipping. Once I replaced that, no more noise.

Link to comment
Share on other sites

  • Supporter

 

Try tilting the filter until the outflow is the highest point, then jiggle it rapidly back and forth to release any air that might be trapped. This is what I have to do with mine, anyway. (It's a SunSun though.)

What kind of noise is it making?

^^ this

 

I also press the primer button while it's filtering. That seems to get the most air out.

 

 

 

Have you checked the impeller shaft? My Sunsun was very noisy when I received it. It turned out the impeller shaft had broken during shipping. Once I replaced that, no more noise.

 

these a great ideas. also check that the bioballs do not have too much room to rattle around in.. ie, i set up 4 sunsun filters for my tanks. one was making a rattle noise, not too loudly but annoying enough. i realized that there weren't enough bioballs in that tray and they were having a party. i added some filter floss to that tray and the filter has been humming ever since.

Link to comment
Share on other sites

  • Regular Member

Thank you for your suggestions everyone :) .

I shook it about a bit and once the air was all out the motor shut up. The media baskets however, are another story. 

 

 

 

 

Try tilting the filter until the outflow is the highest point, then jiggle it rapidly back and forth to release any air that might be trapped. This is what I have to do with mine, anyway. (It's a SunSun though.)

What kind of noise is it making?

^^ this

 

I also press the primer button while it's filtering. That seems to get the most air out.

 

 

 

Have you checked the impeller shaft? My Sunsun was very noisy when I received it. It turned out the impeller shaft had broken during shipping. Once I replaced that, no more noise.

 

these a great ideas. also check that the bioballs do not have too much room to rattle around in.. ie, i set up 4 sunsun filters for my tanks. one was making a rattle noise, not too loudly but annoying enough. i realized that there weren't enough bioballs in that tray and they were having a party. i added some filter floss to that tray and the filter has been humming ever since.

 

 

My bioballs were having a party originally too. The noise was even worse then  :rofl

 

Is it safe to run it with no media baskets to check it definitely is them now?  :hmm

Link to comment
Share on other sites

  • Regular Member

Well hold on are they rattling around because they are not full enough? It could be the media doing the rattling, not the trays. If the trays are already in there with just a little room to move around, you may take up too much space with the padding.  Only one way to find out I guess....  Have you tried running it with the media trays inside but with no media in them?

Edited by DieselPlower
Link to comment
Share on other sites

  • Regular Member

Well hold on are they rattling around because they are not full enough? It could be the media doing the rattling, not the trays. If the trays are already in there with just a little room to move around, you may take up too much space with the padding.  Only one way to find out I guess....  Have you tried running it with the media trays inside but with no media in them?

 

That could well be the case. I'll run it with just the trays tomorrow and buy more media anyway. Thank you for your help. :)

Link to comment
Share on other sites

  • Regular Member

Sorry. Life got in the way. It's the grate at the top of the baskets. I forgot to put it on when I closed it up and ran it and the whole thing was silent besides a hum. I'll try Helen's suggestion for it. Thank you so much for your help guys. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...