Jump to content

Tetra whisper Air Pump


Justin

Recommended Posts

  • Regular Member

I just noticed that my Whisper Pump is vibrating excessively, thus making a lot of noise, and is also getting very hot. I haven't felt before. Could someone do me a huge favor and tell me if it is supposed to run warm? I can't remember it ever being warm. Thanks!

Link to comment
Share on other sites

  • Regular Member

I don't know if a loose screw would make it run hot. I think you might need to flip it over, remove the little white air filter, and replace that.

I was hoping nobody would mention that....... I may have wrapped it in a towel for like 30 minutes so I could actually get some homework done without being annoyed to no end. Once I took the towel off, it eventually cooled down. I didn't know you could replace the white thing.... Interesting. I thought you could only replace the black silicone/rubber part. It seems like the whole thing is replaceable if you really tried. Just a bit of soldering is all it would take.

Link to comment
Share on other sites

  • Regular Member

Haha well it seems the lose screw could cause the vibrating and wrapping a towel around it would heat it up for sure so I think you solved your problem. Good job.

Thanks! I feel good... I solved the problem I partially created. :rofl
Link to comment
Share on other sites

  • Regular Member

You could always wash the little white air filter thoroughly and wait for it to dry.

Is that the thing that has two wires soldered to it?
It's the little white thing I was talking about. It's just a little felt pad.
Link to comment
Share on other sites

  • Regular Member

You could always wash the little white air filter thoroughly and wait for it to dry.

Is that the thing that has two wires soldered to it?
It's the little white thing I was talking about. It's just a little felt pad.
Oh! Maybe I'll do that how then :)
Link to comment
Share on other sites

  • Regular Member

You could always wash the little white air filter thoroughly and wait for it to dry.

Is that the thing that has two wires soldered to it?
It's the little white thing I was talking about. It's just a little felt pad.

That's the pump filter (pad) :)

Edited by dnalex
Link to comment
Share on other sites

  • Regular Member

Alright. Just rinsed it off and waiting for it to dry! Thanks guys!

I think they also sell replacement filter pads, although I've actually never bought one. :rofl

Mine didn't look particularly dirty, but it did have a weird "smoke" coming off of it. Like super micro particles. It was really weird.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...