Jump to content

How can I get rid of this?


Mikey

Recommended Posts

  • Regular Member

I scrubbed almost all of it off of my pothos roots, but being on the intake tube is new and I cleaned that last week.

DSC_0021_zps68026070.jpg

DSC_0023_zps7b454f3c.jpg

DSC_0024_zps81739a0d.jpg

DSC_0025_zpsa808a101.jpg

Link to comment
Share on other sites

  • Regular Member

Well it's definitely not diatoms. It looks more..........hairy. :scared

Black Beard Algae, maybe?

bba-redalgae.jpg

I have no idea how you get rid of it, but if worse comes to worse, you may need to hack off some of those roots.

I think some members here have had experience with BBA, if this is what it is, hopefully they chime in.

Link to comment
Share on other sites

  • Regular Member

That's exactly what it is Georgia. My sworn enemy lol

Mikey is it only on the roots or is it showing up other places in the tank?

You added another light to your tank recently yes?

Link to comment
Share on other sites

  • Regular Member

Showing up on all the roots of my pothos and my intake filter. I don't remember if it was on my plant leaves (not home ATM)

Yes, but they were like that before the light was added.

I wouldn't have any roots left, Tammy :o:rofl3

Link to comment
Share on other sites

  • Regular Member

Oh! I do! How don't do that? (Ratio to water) and I will also be getting flourish On te mail tomorrow most likely :)

Link to comment
Share on other sites

  • Regular Member

Take a look at this, if you have hydrogen peroxide you could follow the full protocol, if not just follow the excel part (and I would do all this outside the tank, put the roots in a separate tank/bucket for treatment) http://www.plantedtank.net/forums/showthread.php?t=203684

Link to comment
Share on other sites

  • Regular Member

Take a look at this, if you have hydrogen peroxide you could follow the full protocol, if not just follow the excel part (and I would do all this outside the tank, put the roots in a separate tank/bucket for treatment) http://www.plantedtank.net/forums/showthread.php?t=203684

Excellent! Okay, so from what I think i got out of that is that I place my fish into a holding tank, remove all the media from the filters into a bucket. Leave all the plants in except moss balls and the. Get H202 at 3% and sdd that to the dosage it said to and rub my filters in high for 15 minuets, drain my tank and refil it, add all the media and stuff and fish and then dose excel at 1 cap per ten gallons and should be all gone?
Link to comment
Share on other sites

  • Regular Member

Yep :) as long as you have somewhere to put your fish in the meantime it's fine to treat the whose tank. I just didn't want your fish in the hydrogen peroxide ;)

Good luck!

Link to comment
Share on other sites

  • Regular Member

I'll clean out the 20 gallon with PP and hot water and then I can move them into there :) ill put the AC 50 on with only their media and nothing else. I'll fill it with new water and then use that water and put it into my tank lol that way nothing is wasted :) (my mom hates water changes)

Link to comment
Share on other sites

  • Regular Member

Awesome idea! If only I had known about this when one of my tanks had really bad algae.

Good luck in your algae removal Mikey!

Link to comment
Share on other sites

  • Regular Member

Thank you! :) I will update the thread on how it goes when I am all done! (I will try and get it done tomorrow, but no promises :P)

Link to comment
Share on other sites

  • Regular Member

Thank you! :) I will update the thread on how it goes when I am all done! (I will try and get it done tomorrow, but no promises :P)

I have bba on my tiny moss driftwood, so let me know how it goes!

Link to comment
Share on other sites

  • Regular Member

I've been double dosing excel and changed my light cycle and added a lot more plants and it's 90% gone at the moment. I'm not a stickler for a algae free, sparkling clean tank, so 90% works for me. I'm sure If I scraped and cleaned everything that I would not have anymore, but I just can't bring myself to clean that much. I feel like if you keep things too sterile, that once something goes off a bit your fish start having trouble :idont Probably all in my head, but it works for me.

Link to comment
Share on other sites

  • Regular Member

I want mine gone because it's ONLY on my plants and filter Intake tube :rofl not on my walls or anything. Just the plants :idont

Link to comment
Share on other sites

  • Regular Member

It will definitely die with fire :rofl

I'll be doing it really soon. QT tank is sterilized. I just need to drain it and rinse out out with scalding water.

I'll let you all know how it goes :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...