Jump to content
Sign in to follow this  
Balaylee

Fluval 304 Input/Output Tubes not locking?

Recommended Posts

I've never used canister filters before so I apologize for not knowing much. I'm trying to get the input and output tubes locked into the lid and I can't get the blue handle all the way down. I don't wanna bust it off so I didn't apply a lot of pressure unless your supposed to. Also any priming tips?

Share this post


Link to post
Share on other sites

Can you provide a picture? I have the newer 06 version and don't know how much different they are

Share this post


Link to post
Share on other sites

Check you havnt got something in there or an oring isnt catching

Share this post


Link to post
Share on other sites

2v0gagy.jpg

And since I can't get the blue handle down It's not air tight enough for me to be able to prime it

Share this post


Link to post
Share on other sites

I had similar trouble when my Fluval was new ..... try lightly coating the rubber seals with some olive or vegetable oil before installing into the filter. You'll find that the outlet/inlet pipes fit in much easier, and the handle will lock down with much less effort.

goodluck_zps5349e862.gif

Edited by Phillyn17

Share this post


Link to post
Share on other sites

Thanks so much! Got everything working!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
  • Create New...