Jump to content

Filter pads slimy


Finnage

Recommended Posts

  • Regular Member

Usually, I rinse my filter pads once a month with no problem. Last I rinse them was 2 weeks ago, but today my filter was really clogged, which never ever happened before.

When I took them apart, all of the filter pads were covered in slime. Does anybody know what they are? Are they just algae?

FYI, I'm on my 4th round of prazi this week, but I've treated with prazi a couple of times before and have never encountered this.

Link to comment
Share on other sites

  • Regular Member

When you say slime, is it algae? like brown or green? Or is it clear?

Maybe try rinsing it every 2 weeks instead and see if that makes a difference.

Link to comment
Share on other sites

  • Regular Member

I didn't know it was slimy until I start rinsing them. So, no it was not visible as algae.

I am not really worried because parameters are not affected. Just curious, that's all.

Link to comment
Share on other sites

  • Regular Member

Is this an HOB filter? When I had HOB filters, the sponge would progressively collect BB and other organic waste which you can never truly clean completely, otherwise you lose your BBs, but over time they do slowly build up much more gunk and slime (biofilm) on the filters. You may have to do what I did, which was rinse them vigorously in used tank water when you do your PWCs, or more often. Don't worry as the BBs attach themselves very securely and won't dislodge from the sponge, but this is the only way to get most of the biofilm from the interior portion of the filter which will keep it from clogging much more quickly. My HOB would even over-flow the filter. Why I had to end up getting an canister even on my old 55-gallon.

Link to comment
Share on other sites

  • Regular Member

Yes I do have plants but my filter intake has a sponge covering it, so usually the plant materials are collected there as opposed to inside the filter.

As for diatoms, I do have some but wouldn't call them an outbreak, no significant increase then in previous weeks.

It might be biofilm. How quickly do they appear? I just rinsed my filter 2 weeks ago and they were not the least bit slimy.

Btw, yes the filters are both HOBs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...