Jump to content

Search the Community

Showing results for tags 'AC 70'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome Start Here!
  • General Goldfish Area
    • New to the hobby or new to Kokos.
    • Classifieds and Reviews
    • Goldfish Discussion
    • Goldfish Food
    • Equipment and Water Care
    • Goldfish and Ponds.
    • Goldfish & Plants.
    • Types of Goldfish
    • DIY and Tips
    • Goldfish Breeding
    • Disease Diagnosis/ Treatments
    • Treatments
    • Quarantine/ New fish arrival.
  • Photo Area
    • Goldfish Photos / Videos
    • Tank Photos
    • Koi and Goldfish Shows. (photos and videos)
  • Koko's Kritters
    • Tropical and Betta Fish Section
    • Marine fish
    • Snails and Crustaceans

Categories

  • Frequently Asked Goldfish Questions
  • Aquatic Equipment
  • Aquatic Plants
  • Disease Information
  • DIY Projects
  • Goldfish Food
  • Goldfish Keeping Tips
  • Research Articles
  • Reviews
    • Book Reviews
    • Product Reviews
  • Water Quality Articles
  • Betta Care
  • Contest Photos
    • Goldfish Photo Of The Week

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Email


Interests


Goldfish Blog


Age


Referred By


How many Goldfish


Location

Found 2 results

  1. I've had no problems with my AC70 for a year, and now it's starting to drive me nuts. The motor began to make these awfully annoying and loud grinding sounds, like the impeller was grinding against the chamber. I tried cleaning it this morning and no dice. Can someone tell me the proper way of cleaning the impeller chamber, by the way? I feel like I'm doing it wrong. Also, another weird thing. It always starts in the morning. Never at any other time. It woke me up this morning. Here's a video of the noise: \Sometimes it does it continuously, other times it has "bursts." I don't know what to do! Is there a chance of a fire happening with all the friction going on in there? Is a warranty still applicable? Like I mentioned, the filter has been running for almost a year.
  2. Today I cleaned my Aqua Clear 70 for the first time. Boy, I guess gold fish are dirty! I can see how easy it would be to neglect cleaning it as we don't see it in the water. I also got rid of the charcoal bag that came with it - and replaced it with 3 Rite size filter media pads cut to approximate dimensions as the charcoal bag and added an extra bag of AC 70 bio-max media. Thanks Tithra Tomorrow, I'm going to go to a LFS about an hour away to buy some Prazi Pro for my guys and look to see what price they have on their media for the Fluval as I will have to replace those charcoal bags too. For now, I'm content just doing the one and will do the Fluval in a week or so to avoid any mini cycles. Today, I also bought some charcoal bags for the AC 70, in case I need them to remove the Prazi later on. (Not sure, but doesn't hurt to have it to remove meds anyway). I also might get another fish since I'm doing Prazi and salt, might as well get it over with.
×
×
  • Create New...